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Foreword
Successful implementation of climate change mitigation policies related to Reducing Emissions
from Deforestation and Forest Degradation Plus (REDD+) would require information about forest
biomass, land cover resources, as well as forest resources. Remote sensing (RS), a valuable tool for
generating forest cover maps and estimation of forest carbon stocks, and its application to forest
cover mapping were explored by Deutsche Gesellschaft für Internationale Zusammenarbeit (GIZ).
In the absence of historical forest inventory data, RS can also provide historical information on
forests given available temporal satellite imagery, which are freely available to users, such as those
acquire by the Landsat 7 ETM+ sensor.
GIZ, in collaboration with the Department of Environment and Natural Resources Forest
Management Bureau (DENR-FMB), is implementing the project “Climate-relevant Modernization
of Forest Policy and Piloting of REDD in the Philippines” with funding from the International
Climate Initiative of the German Federal Ministry for the Environment, Nature Conservation and
Nuclear Safety (BMU). The Project supports the implementation of the Philippine National REDDPlus Strategy (PNRPS) with, inter alia, capacity building on measuring, reporting, verification (MRV)
for REDD+, using satellite imagery for forest and land use change analysis.
In line with the MRV activities for REDD-plus, GIZ in collaboration with the University of the
Philippines Diliman – Department of Geodetic Engineering (UP-DGE) organized and conducted
a Training-Workshop on Remote Sensing for REDD+ MRV System last March 28, April 1, and
April 4-5, 2011 at the Remote Sensing Laboratory of UP-DGE. The training workshop’s goal was to
introduce important stakeholders to (1) basic remote sensing concepts, (2) pre-processing techniques
of Landsat 7 images, and (3) deforestation detection as well as accuracy assessment, which are all
valuable concepts that will help them understand the capabilities of remote sensing in terms of
generating fast and cost-effective forest cover maps, which are useful for monitoring changes and
vital for the MRV System Development.
This manual was consolidated in close collaboration with Mesa-Consult and UP-DGE, and was
prepared to guide the participants of the said workshop. We hope that this manual will become a
useful and effective guide for Geographic Information System (GIS) / RS practitioners, aiming to
use free satellite imagery such as the Landsat 7 ETM+ images.

Dr. Bernd-Markus Liss
GIZ Principal Advisor
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Data Requirements
Landsat 7 ETM+

The Landsat 7 ETM+ images used in this training manual were downloaded from U.S. Geological
Survey (USGS) using EarthExplorer (http://earthexplorer.usgs.gov/). This manual is specific to
Landsat 7 ETM+ imagery with the Scan Line Correction (SLC) turned on. For Landsat 7 ETM+ with
SLC-off, additional pre-processing steps are required and not shown in this manual.
How to Download
1. Go to the EarthExplorer website (http://earthexplorer.usgs.gov/). Create an account (this is
necessary for downloading).

2. Under the Search Criteria, define the area of your interest (in this case, Leyte Island). Click USE
MAP so you can use the map (on the right side) to define your area.

3. It will automatically create a boundary around an area. Change that by clicking and dragging the
numbered balloons in such a way that it will cover your area of interest (e.g. Leyte Island).

iii | F e a t u r e E x t r a c t i o n P r o c e s s i n g u s i n g L a n d s a t 7 E T M +
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4. Under Date Range, change the dates to your desired dates (e.g. 01/01/1999 to 12/31/2002 to
look for images available between years 1999-2002).

10
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5. Once you are satisfied with the area you have chosen, click on the Data Sets tab. Look for
Landsat Archive > L7 ETM+ SLC-on (1999-2003). Check the check box for that option and click
Results >>. Select the most cloud free data.

v|Feature Extraction Processing using Landsat 7 ETM+
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6. For the selected area of interest (e.g. Leyte Island), 100 results will appear for the Landsat 7
ETM+ SLC-on (1999-2003). Click on the
areas are covered by each file.

7. Click the

tool for some of the results so you can preview what

tool for each file. The Download Scene window will appear. Click Download.

8. Once you have downloaded the files that you need, they will be found in your download folder.
Extract the compressed files into a folder. These files can readily be opened in ENVI.

Software Requirements and Prerequisites for Users
ENVI© software was used to apply the processing steps found in this manual. The users of this
manual are assumed to be familiar with Remote Sensing (RS) softwares such as ENVI and it is an
advantage if they are also knowledgeable with RS concepts.

vi | F e a t u r e E x t r a c t i o n P r o c e s s i n g u s i n g L a n d s a t 7 E T M +
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Software Requirements and Prerequisites for Users
ENVI© software was used to apply the processing steps found in this manual. The users of this
manual are assumed to be familiar with Remote Sensing (RS) softwares such as ENVI and it is an
advantage if they are also knowledgeable with RS concepts.

A. Radiometric Calibration of Satellite

A. Radiometric Calibration of Satellite
A.
Landsat
A. Calibration
Landsat
Calibration
Use
Landsat
Calibration to convert Landsat MSS, TM, and ETM+ digital numbers to spectral
radiance or exoatmospheric reflectance (reflectance above the atmosphere) using published postUse Landsat
Calibration
launch
gains and
offsets. to convert Landsat MSS, TM, and ETM+ digital numbers to spectral
radiance or exoatmospheric reflectance (reflectance above the atmosphere) using published postlaunch gains and offsets.

The spectral radiance (Lλ) is calculated using the following equation:
The spectral radiance (Lλ) is calculated using the following equation:
Where:
 QCAL is the calibrated and quantized scaled radiance in units of digital
Where:
numbers

QCAL is the calibrated and quantized scaled radiance in units of digital
 LMIN
λ is the spectral radiance at QCAL = 0
numbers
 LMAXλ is the spectral radiance at QCAL = QCALMAX
 LMINλ is the spectral radiance at QCAL = 0
 LMAX
radiance
at QCAL
= QCALMAX
λ is the spectral
LMIN and LMAX
are derived
from values
published
in Chander,
Markham, and Helder (2009).
λ

λ

LMINλ and LMAXλ are derived from values published in Chander, Markham, and Helder (2009).
 QCALMIN is the minimum quantized calibrated pixel value (corresponding to LMINλ) in DN.
 Valid values are as follows:
 QCALMIN is the minimum quantized calibrated pixel value (corresponding to LMINλ) in DN.
 Valid1:values
are as follows:
LPGS products

1: NLAPS products processed after 04 April 2004
1:NLAPS
LPGS products
0:
products processed before 05 April 2004
1: NLAPS products processed after 04 April 2004
0: is
NLAPS
productstoprocessed
before
05 April 2004
When metadata
not available
determine
the appropriate
values, QCALMIN is set by default to

1 (TM and ETM+) or 0 (MSS).
When metadata is not available to determine the appropriate values, QCALMIN is set by default to
1 (TM and is
ETM+)
or 0 (MSS).quantized calibrated pixel value (corresponding to LMAX ) in DN. Valid
QCALMAX
the maximum
λ

values are 127, 254, or 255. When metadata is not available to determine the appropriate values,
QCALMAXisisset
thebymaximum
calibrated
QCALMAX
default toquantized
255 (TM and
ETM+) orpixel
127 value
(MSS).(corresponding to LMAXλ) in DN. Valid
values are 127, 254, or 255. When metadata is not available to determine the appropriate values,
QCALMAX
is set
by default
(TMofand
ETM+)
127 (MSS).
The
resulting
radiance
(L ) istoin255
units
watts
per or
square
meter per steradian per micrometer (W/
λ

m2*sr*µm)).
The resulting radiance (Lλ) is in units of watts per square meter per steradian per micrometer (W/
m2*sr*µm)).
The exoatmospheric reflectance (ρp) is calculated using
the following equation:
The exoatmospheric reflectance (ρp) is calculated using
the following equation:

Where:

 Lλ is the spectral radiance
Where:
 Lλ is the spectral radiance
2|Feature Extraction Processing of Landsat 7 ETM+
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 d is the Earth-Sun distance in astronomical units
 ESUNλ is the mean solar exoatmospheric irradiance. ENVI uses the ESUNλ values from the


Landsat 7 Science Data Users Handbook for Landsat 7 ETM+. ENVI uses the ESUNλ values
from Chander and Markham (2003) for Landsat TM 4 and 5.
θs is the solar zenith angle in degrees.

Laboratory Exercise
Objective
To perform calibration of Landsat ETM+ data with ENVI’s Landsat Calibration Tool.
Data
Landsat GeoTIFF File with header information found in this directory
D:\RSWORKSHOP\LandSat7\April 11, 2011.

A.1. Absolute Calibration
1. To open your Landsat GeoTIFF file with header information from ENVI’s main menu bar click
on File > Open External File > Landsat > GeoTIFF with Metadata. Then Enter Landsat
MetaData
Filenames
dialog
opens
as
shown
below.
Navigate
to
D:\RSWORKSHOP\LandSat7\April 11, 2011.

2. Select the metadata file L71113053_20010411_MTL and click on Open.
This will load all the bands of the Landsat image data on the Available
Bands list window as shown.
Landsat metadata files are preferred since ENVI will use the metadata to
automatically determine calibration parameters. The Landsat Calibration
tool only works with file formats described in Opening Landsat Files.

3|Feature Extraction Processing using Landsat 7 ETM+
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3.

Load a true color composite of the Landsat data as shown below.

4. Inspect Data/pixel values with the Cursor Location/Value tool. From the Image window, click
on Tools > Cursor Location/Value.

Calibrate Data
5. From ENVI's main menu bar select Spectral > Preprocessing > Calibration Utilities >
Landsat Calibration. Select the 3rd file to calibrate bands 1-5 and 7. Click on OK.

The dialog box is also accessible from the following
 Basic Tools > Preprocessing > Calibration Utilities > Landsat Calibration
 Basic Tools > Preprocessing > Data-Specific Utilities > Landsat TM > Landsat Calibration
4|Feature Extraction Processing using Landsat 7 ETM+
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 Basic Tools > Preprocessing > Data-Specific Utilities > Landsat MSS > Landsat Calibration
 Spectral > Preprocessing > Calibration Utilities >Landsat
Calibration
 Spectral > Preprocessing > Data-Specific Utilities >Landsat TM >
Landsat Calibration
 Spectral > Preprocessing > Data-Specific Utilities >Landsat MSS
> Landsat Calibration
6. The ENVI Landsat Calibration dialog box appears as shown.
ENVI determines the calibration parameters from the
metadata and populates the dialog accordingly.
For Landsat 7 GeoTIFF files without metadata, the dialog box
defaults to a date of January 1, 1984 and a sun elevation
angle of 90 degrees. You can obtain calibration parameters
from the EROS Data Center as CPF files and MetaData files.
However, most Landsat GeoTIFF data now come with
metadata, so if you use File > Open External File > Landsat
>GeoT1FF with Metadata to open the data, ENVI will
automatically determine the calibration parameters.
You can edit the Data Acquisition Month/Day/Year, and Sun Elevation (deg) values if you
want to override the metadata-derived values.
7. Select Reflectance as the desired Calibration Type using the
radio button.
If you selected a thermal band for input (Bands 61 or 62), the
calibrated output will be in temperature (in degrees Kelvin).
8. Gain/Bias or Lmin/Lmax calibration values are automatically
calculated from the associated metadata file(s). Click Edit
Calibration Values if you want to enter your own calibration
values instead of the metadata-derived values, or if the
metadata contains Gain/Bias values of 0, or if there is no
available metadata file.
9. The Edit Calibration Values dialog appears. Enter new values
for Gain/Bias or Lmin/Lmax as needed, and click OK. Or, click
Restore Dataset Parameters to reset the values to what was specified in the metadata.
If you used File > Open External File > Landsat > GeoTIFF to open a .TIF file in Step 1, ENVI
cannot automatically determine the Gain/Bias or Lmin/Lmax values, so you will need to
enter them manually.
Follow these steps to continue:
The ENVI Landsat Calibration dialog contains two additional radio buttons: Lmin-Lmax and GainBias. Select either option, depending on the processing type, and click Edit Calibration Values.
The Edit Calibration Parameters dialog box appears.
For Landsat 7 ETM+ data only, select the Low or high radio button for Radiance Range. Enter
5|Feature Extraction Processing using Landsat 7 ETM+
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Gain/Bias or Lmin/Lmax calibration values.
10. Click OK to continue.
11. In the ENVI Landsat Calibration dialog box, select output to File or Memory. Click OK.
When complete, ENVI adds the resulting output to the Available Bands List.
12. Load the resulting output as a true color composite and inspect the pixel values with the
Cursor Location/Value tool.
13. Create an image showing calibrated Radiance values by repeating steps 5-12.
14. Calibrate the Thermal Bands (Bands 61 and 62) to generate an image showing
temperature values.

A.2. Relative Calibration (Flat Field Calibration)
Use the Flat Field calibration to normalize images to an area of known "flat" reflectance. This is
particularly effective for reducing hyperspectral data to relative reflectance. The method requires
that you select a Region of Interest (ROI) prior to execution.
The average spectrum from the ROI is used as the reference
spectrum, which is then divided into the spectrum at each
pixel of the image.
1. Define an ROI over a spectrally flat area (see Drawing
ROIs).To do this, with a true color composite of the
image loaded, on the image window's menu bar, click on
Overlay > Region of Interest. This will open the ROI tool.
Draw an ROI on the Image window. Bright areas such as
clouds for area of interest.
2. From the ENVI main menu bar, select Basic Tools >
Preprocessing > Calibration Utilities>Flat Field. The
Input File dialog box appears.
3. Select an input file and perform optional Spatial Subsetting and/or Spectral Subsetting, then
click OK.
4. Select the average spectrum to use for the flat field calibration by selecting the ROI name in
the Select Calibration from Regions column. The selected ROI name appears at the bottom of
the window in the Selected Item field.
5. Select output to File or Memory.
6. Click OK.

6|Feature Extraction Processing using Landsat 7 ETM+
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B. Cloud Masking in ENVI 4.5
1. Open ENVI 4.5 by clicking on the icon:
2. From the ENVI main menu bar, select File > Open Image File. The open dialog box will appear.
Browse for the training data set in the Landsat 2005 folder. Select and open the file:
L5113052_05220050124_b123457_sub
3. From the Available Bands
List dialog box
a. Click on the RGB
radio button,
marked 3.1
b. Then select the
B3, B2, and B1 in
that order,
marked as 3.2.
Notice the radio
button below the
RGB dialog box
shift from R to G
then finally to B.

Question: what will happen if you select a
different band number for the RGB dialog box?
Try it and notice the difference.
4.
The Composite you just made will open
as Display #1
This band arrangement is called TRUE COLOR
The Bands are arranged in this manner:
R = band 3
G = band 2
B = band 1

7|Feature Extraction Processing using Landsat 7 ETM+
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5. Create a new Display Window
a. From the Available Bands List, Hold-click on Display #1 button, then click on New
Display as show

b. A new blank window will appear

6. From the Available bands List,
a. Select the Gray Scale Radio
Button
b. Click on Band 4
c. Click Load Band. Make sure
that Display #2 is selected
as shown
d. A grayscale image of band4
will be displayed in
Display#2

Questions:
1. Can you distinguish clouds in the
image?
Double click any of the three (3) windows
as shown in the right panel.
2. Double clicking on which panel opens up
a new window?
8|Feature Extraction Processing using Landsat 7 ETM+
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3. What various information does the new
window provide?
Image window

Scroll window

Zoom window

7. Cursor Location window

a. Try to browse around the image in step 6 by moving the RED RECTANGLE in Scroll
Window. Notice the effect in the Image Window. Then move the RED RECTANGLE in
the Image window, notice the effect on the Zoom Window.
b. Move the cursor over various locations in the image, scroll and zoom window. Notice
the DATA value. What do the changing numbers refer to?
c. By just using a single band (grayscale / monochromatic) representation of the area,
can you easily determine features on the image such as forest, shrubs, grasslands,
clouds, shadow and built up area? What would help you identify these areas on the
image?

22
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8. Linking Displays

a. From the LINK DISPLAYS window you can set the Link Size / Position to Display#1 or #2.
b. Experiment using either of the two and note which one moves around relative to the
other image

10 | F e a t u r e E x t r a c t i o n P r o c e s s i n g u s i n g L a n d s a t 7 E T M +
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c. Drag the RED RECTANGLE in display#1 or display#2. Notice how each of the display panel
reacts.
d. Click-hold on the image window in either display#1 or display#2. Notice how each of the
display panel reacts.
e. Describe how the linked window panels help you in determining the various features on
the image.

9. Building a mask
a. From the ENVI main menu bar,
select Basic Tools > Masking > Build Mask
b. Select Display#2
c. Click OK
d. From the link display, locate clouds features
e. Using the Cursor Location Window, determine
the minimum and maximum DN values
for the clouds. Write down the range of values.
f.

From the Mask Definition Window,
click on Options > Import Data Range

g. Input the values from Step E into the form,
make sure that only BAND4 is selected in the
Select New Input window
h. Click OK
i.

From the mask definition window, select a file name, type “Mask1”
Choose a location to save your mask, then click APPLY. This will create a new image
in the Available Bands List Window.

10. Refining the Mask
a. Create a new Display window #3 (Step5)
b. Load Mask1 into Display #3
c. Link all the three (3) displays (Step 8)
d. Check to see if all/most of the clouds are included in the mask

24
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e. Use the Pixel Locator Window to determine
the values of the excluded or missing patches
of clouds in the mask.
You may also find values which should not be masked
out. These values may be similar in response to clouds.
Note these values then revise the mask accordingly.
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C. Mosaicking with ENVI
Using mosaicking to overlay two or more images that have overlapping areas (typically
georeferenced) or to put together variety of non-overlapping images and/or plots for presentation
output (typically pixel-based). You can mosaic individual bands, entire files, and multi-resolution
georeferenced images. You can use your mouse or pixel-or-map-based coordinates to place images
in mosaics and you can apply a feathering technique to blend image boundaries. You can save the
mosaicked images as a virtual mosaic to avoid having to save an additional copy of the data to a disk
file. Mosaic templates can also be saved and restored for other input files.
Data:
D:\RSWorkshop\Landsat\2005\
L5113052_05220050124_b123457_sub
L5113052_05220050124_b123457_sub
Building Georeferenced Mosaics
Use Georeferenced Mosaicking to automatically overlay multiple georeferenced images. You can
mosaic multi-resolution georeferenced images, apply feathering and color balancing to the images,
and import georeferenced images and non-georeferenced images into the same mosaic.
1. Load the following image (*.TIF) datasets to ENVI from the main menu> Open Image File.
This will open the Enter Data Filenames dialog box. Navigate to the
D:\RSWorkshop\Landsat\2005\
and
select
the
following
datasets:
L5113052_05220050124_b123457_sub and L5113052_05220050124_b123457_sub. Click
Open.

This will load the files in the Available Band List Dialog box.
13 | F e a t u r e E x t r a c t i o n P r o c e s s i n g u s i n g L a n d s a t 7 E T M +
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2. To build mosaics using georeferenced images, select
Map>Mosaicking>Georeferenced from the ENVI main menu
bar. The Map Based Mosaic dialog box appears. Use this box
to set the output mosaic parameters and to select
images
to
mosaic.

3. To import files into the dialog box, click on Options>Import Files and Edit Properties. Select
the two file, Click on Ok.

4. For the 1st selected images, set the parameters on the dialog box that open as shown. Note
that Color Balancing is set to Fixed here. This sets the image as the reference for color
balancing. On the succeeding image/s, this parameter will be set to Adjust. It is a rule that at
least 1 image is set to Fixed. Click on Ok.

27
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5. This will display the parameters for the next image. Set the parameters as shown below. Click
on Ok.

6. This will display the Mosaic dialog box with the images for mosaic.
7. On the Mosaic dialog box, click on File>Apply. This will open the Mosaic Parameters window.
Click on Choose and supply filename. Click on Ok. The output file will be added on to the
Available Bands List Dialog Box. Display the file.

15 | F e a t u r e E x t r a c t i o n P r o c e s s i n g u s i n g L a n d s a t 7 E T M +
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D. Feature Extraction (Classification)
For this exercise, we will only explore how to extract features using the Maximum Likelihood
Classifier
1. Open ENVI 4.7 by double clicking on its icon.
2. Load the composite 145 into Display#1.
3. Visually explore the scene and tentatively decide on your classes based on what you could
visually differentiate from the scene. Quickly note the classes and how they correspond to
your composite.
4. Define a Region of Interest by following these steps
Region of Interest (ROI)
a. From the Image Window click on Tools > Region on Interest > ROI Tool

There are several ways of defining a ROI…
Click Options > Band Threshold to ROI…
select band1 band from the Select Input
Band window, then click on OK

From the band threshold to ROI Parameter
Window, input the Minimum and Maximum Threshold Value similar the CLOUD MASKING EXERCISE

16 | F e a t u r e E x t r a c t i o n P r o c e s s i n g u s i n g L a n d s a t 7 E T M +
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This time, open and load band 1 into a new display window, inspect the minimum and maximum
values for clouds via the Pixel Locator window. As an example, try to input the following values then
click OK.

Question: why use band 1 to select ROI for clouds?
Hint: try to load all the bands in a separate display window, link the displays; then browse for
the clouds in one band then compare it to the other bands. Which band clearly defines the
clouds?

A new window stating the number of pixels selected by the threshold… just click on OK. The new ROI
will appear in RED as shown below.

Next, load Band5 in a new window. Again, using the Pixel Locator utility, scan the dark patch area
below the image. Note its Data value.
Question: Do you notice a sudden rise in value when you hover your mouse over a
“white spot”? What feature does the dark spot represent on the ground? How about
the white spot somewhere in the middle? Close all the single bands you just loaded
[WATER, CLOUDS]

You can create another Band threshold to ROI or you can delineate new ROI via polygon (free hand
drawing) or via rectangle (rectangular shape). From the ROI Tool window, click on
ROI_TYPE > Rectangle
Multi part: OFF

30
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From the ROI Tool Window, click on New Region, then tick the Image Radio Button
as shown:

By ticking the Image radio button, you are telling the software that you will be
defining a new ROI from the IMAGE WINDOW. Try to define a ROI on the SCROLL /
ZOOM window. What happened?
Now, define a rectangular ROI in your image window, covering a homogenous water
body in the south area of the image.
When done, right click inside the rectangle you just created to form a solid rectangle
as shown below.

18 | F e a t u r e E x t r a c t i o n P r o c e s s i n g u s i n g L a n d s a t 7 E T M +
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EDITING ROI
Load the true color (321 composite) of the area. Link the
display#1 & display#2. Browse to the south-west area where
settlements are included in the ROI for clouds.
From the ROI Tool Window, select File >
Export ROI’s to EVF. Select the ROI you
want to export, fill in the Output Layer
Name, then choose an output filename for
the EVF.
Load the newly converted vector files (EVF)
onto the same display as the 321
composite.
If you zoom in on the south
west region you will find
several Cloud ROI’s over the
settlement areas.
Question: why was the
settlement area marked with
a ROI for clouds?
In the zoom window, right-click on
the vector, then click on Select
Vector, the vector feature should
then have a green shaped
diamond in the middle meaning it
is already selected; then right click
again, select Delete Vector from
the context menu. Do the same
for the remaining vectors.

When done, go to the Vector Parameters: Edit
Existing Vectors Window. Select Edit > Save
Changes Made to Layer

After saving, click on File > Export Active Layer to ROIs
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This window will appear, click on appropriate
radio button and OK:

After converting from EVF (ENVI Vector Format) to ROI.
The new ROI will appear in the ROI Tool window as
such. You can now delete the OLD ROI for clouds by
selecting it on the right side, then click on DELETE ROI
You will then be left with just 2 accurate ROIs.

Time to create a new ROI. Let us define a new
ROI for the settlement area. In the composite
145, the settlement area is somewhat colored
purplish. Create a new ROI covering the said
area.
Click on New Region, then the new Region#2 will
appear in the ROI Tool Window as such:
From the Region#2 row, Right click on BLUE, then
select the appropriate tabs to arrive to your new
color of choice for the current ROI.
Here, I will select the Magenta1

Here the settlement ROI is already defined
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Let us define another ROI for the Grasslands by following the same steps. Grasslands,
corresponds to the magenta in the composite 145. Note that the grassland (red box) area is also
accompanied by some barren land (orange box) as shown here with the true color composite

To help us in defining the ROI, go to the ROI Tool
Window, go to ROI Type > Point.
Making sure you select the right class, start to
define just 1 point from your Scroll Window,
then from the ROI Tool Window, click on Grow.
When you are not satisfied with how the ROI
expands, just cancel the whole step and find a
suitable seed pixel and re-do the process
Question: how do you change the ROI Name to
reflect the appropriate class in the ROI Tool
Window?
Shown here is a single pixel which has expanded to
cover adjacent pixel with more or less the same
characteristics

You can go on and create
additional ROI for the following
classes:
Bare soil
Brush
Crop
Grassland
Cloud (water)
Shore/sand
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5. How do we know if our classes are separable? What is separability of classes?
From the ROI Tool Window, click on Options > Compute ROI Separability….
This will generate a new
window, select the
appropriate file to generate
the separability from, click
OK. The ROI Separability
Calculation window
appears. Select the Input
Regions (ROI), you could
select a few regions as
shown, or you could select
all. Click OK after selecting
your regions.
The ROI Separability Report Window appears after clicking OK.
This window shows the Jeffries-Matusita Distance, Transformed Divergence
Question: What do these numbers mean?
6. Extracting Features
a. From the Main ENVI Menu click on Classification > Supervised > Maximum Likelihood
b. From the Classification Input File window, select the appropriate file and click OK

c. The Maximum Likelihood Parameter Window will appear. Select the appropriate
Classes from Regions for inclusion. Choose whether to output to File or Memory. If
you choose to save to a File, select the file name and location to save the classified
image. Then click OK
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The Classified Image will be displayed in the Available Bands List. Load it into a new Display Window,
then Link the displays. Browse and check with the True Color Composite. Notice the salt-n-pepper
appearance of the classified image.
Question: what can we do to improve the image?
Next steps?
We can do Post Classification Processing:
Class Statistics, Confusion Matrix,
Clumping and Sieving, Combining
Classes, Overlaying etc.
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